From Linguistic Team International Wiki
Jump to: navigation, search

Welcome! In this tutorial we are going to go through some of the most useful functions and features of the subtitle editing program Subtitle Workshop. SW is a powerful tool - it has many abilities that might help you in a wide variety of situations. Here we will focus on the commands you will need the most when working on a subtitle file, and also on how to perform these operations in an efficient (time-saving) manner.

First you will need to download the program. SW is free and open source. Version 2.51 is the most popular one, and our choice for this tutorial. You can get it from here.


Configurations:

  • After you have installed it, you can drag and drop a subtitle file on the program's icon on your desktop. That will load the file. It your language's letters don't show as they should, be sure to check the Troubleshooting section here below.
  • The next step is to configure SW's backuping settings. Go to Settings=>Settings. From the Save menu, put a tick on "Save work automatically every" and then choose 1 minute from the box. In this way your work will be safe in case your computer gets restarted or something like that.
  • Next you will need a video file of the video that you'll be subtitling. You can obtain that through various ways, one being to use Firefox's DownloadHelper Add-on. When having the video file, go to Movie=>Open in SW and select it. If the video doesn't play or gives you an error, check the Troubleshooting section below.
  • When you've loaded the video, click on the third button from left to right just below SW's video player. That will make the subtitles change in sync with the video.
  • SW also has the ability to display both the transcription and the translation on the same screen. Go to Edit=>Translation=>Translator mode. Personally, I prefer to work with seeing the translation only, while following closely how well the subtitles flow in terms of timings and structure. I have the transcription open in the Notepad++ text editor and constantly refer to it. Notepad++ also remembers how far I've reached.


Working on the subs - Time manipulation

  • If you need to move around the video, double click on a subtitle line (or "string", as they are also called), and it will take you to that string's beginning time. This makes it very easy to navigate. Also, Ctrl+Space is the shortcut for starting and stopping the video (it can't be just Space since you use that key all the time when editing the subs).
  • To set a start time for a string, play the video and pause it exactly where you think the subtitle should appear. (For better precision I put my mouse over the Stop button and press it exactly on the desired spot.) After that, press Alt+C, which will make the subtitle's beginning time the same as the current time of the video.
  • To set the ending time, stop the video precisely on the desired place and press Alt+V. The beginning time of the next subtitle will automatically be pushed back to 35 ms after the ending time of the current subtitle.
  • If you still need to adjust it just a bit, below the subtitle lines there is Show and Hide time - select any of the three numbers that comprise the milliseconds and use the up or down arrow on your keyboard to increase or decrease the time with 100 ms. (Make sure there is no overlapping with the adjacent strings. Change their times, too, when needed.)
  • After manipulating the times, be sure to watch that point of the video and see how well the transition between the adjusted strings flows. The usual workflow is: adjust-watch-adjust-watch, until you are satisfied.


Working on the subs - Space distribution

  • Inserting a line break, as usual, is done by simply hitting Enter. The trick here is to determine the best place for the line break. These guidelines, which are relevant to both division of a single-lined string into two lines and division of a string into two strings, can be of help to you: String Division. (After thinking for some time over this and getting some practice, the string division will become intuitive to you - you don't necessarily need to make a syntactical analysis of the sentence.)
  • A very important consideration is to have your subtitles spread on the screen to a maximum of two lines. What this means in practice is that you have to limit both your line and your string's length. SW helps you in this by counting the number of symbols of both the individual lines and the whole subtitle. Different subtitlers use different upper limit for their lines, but based on the TV industry standards, I would suggest that you don't go over 40 characters per line (respectively, 80 per string).
  • If you have a string with more than 80 characters, there are a few things you can do:
    • Transfer a part of the string (while considering the string division guidelines) to an adjacent string. Then watch the video and see how the transition between the two strings occurs. Is it flowing well? You will likely need to adjust the timings every time you transfer some words. Refer to the above section to see how to adjust them most easily.
    • Another way is to divide the subtitle into two smaller subtitles. The shortcut for this is Ctrl+Shift+D. (You can play with some features in the menu that comes after you press this shortcut. Explore them.) Again, after the division, you need to watch that place in the video and make the transition point good in terms of timings.
    • Probably the most labor-intensive way is to create a new string (with the Insert key) and transfer a part of your string there. You will need to set the beginning and ending time of this new string, while adjusting the times of the adjacent strings. But inserting a new subtitle can be very useful for some situations - for example, when you need to make a single sentence in its own string.
  • It's also possible that you need to combine two strings into one. In this case select the two strings and press Ctrl+K. Unless the duration of the subtitle becomes too long, you probably won't need to do anything to the timings.

Automatic error-checking

  • While you're working on the subs and after you're done with them, you can perform some of SW's automatic quality-checks. To run the check, go to Tools=>Information and Errors=>Information and Errors (Ctrl+I). Be sure to NOT click on the "Fix errors!" button, as we have not configured the settings yet.
  • To configure the settings, click on the "Settings" button in that same window. In the window that will come up, there are various things that you can select to check for. Here we'll discuss only the most important. On the Advanced tab, for "Too long line" put 41 characters. On the Check for tab, most of the things are pretty useful. I've left unselected things like "Prohibited characters", "OCR Errors" and "Spaces before custom characters". On the Fix tab, the only thing I've selected is "Overlapping subtitles". That's because sometimes there are many subtitles where the ending time of the first and starting time of the second one are the same. SW can fix these by putting 35 ms gaps between them. But you'll never need to do this if you're using LTI subtitles as your starting point. Then on the Unnecessary spaces tab, I've got everything selected.
  • With the above configurations set up in this way, SW will just inform us about possible errors and we will go and manually fix them. As of now, unfortunately, software can't understand much of our human languages, so we need to do the fixes ourselves.
  • So, after having all these configured, we press Ctrl+I again and see what comes up. Double clicking on an error will take us right to that subtitle, where we can make the necessary adjustments. After that we press Ctrl+I again and move on to the next one. You'll probably have there some things that are detected as errors but are actually fine. Just ignore these.
  • There is another subtitle editing program, VisualSubSync, which has a very important feature. After installing the program, go to File=>New project, load your subtitle file and then click on the "Create new project" button. After that, go to JS Tools=>Quick Stats. It will give you the readability of your strings based on a "number of characters per second" formula. If there are strings that need adjusting, you can go to Edit=>Error checking=>Check errors and it will show you existing errors. Just clicking on a string will take you to it.
  • A very good idea is to have a document somewhere where you've listed all the checks you need to perform after finishing work on a subtitle (timings, spell-check, etc.). This way you won't forget!


Additional features

  • I've experimented with the "Smart line adjust" feature and got some decent results. It automatically puts line breaks in your long single lines. In Settings=>Settings, in the Advanced menu, select the number of characters below the "Two lines if longer than" option (I have mine on 36 characters). Then select all the subs (Ctrl+A) and go to Edit=>Texts=>Smart line adjust (Ctrl+E). Keep in mind that you will need to review all the automatic work done by SW. But this will definitely save you a lot of effort.
  • There are lots of other things you can use SW for. When you've gained experience with it, go to the Help file and read about the various functions. You will start grasping and remembering more and more of what's explained there.


Troubleshooting

  • One of the limitations of this program is that it doesn't work with the UTF-8 encoding. Depending on your language, it may or may not display your characters correctly. If it doesn't display them right, you can convert your subtitle file to ANSI encoding and try with that.
    • To convert back and forth between encodings, I use the Notepad++ software. Open the subtitle file with it and go to Encoding, then convert to the desired encoding.
  • After having converted to another encoding and loading the subs in SW, if they still don't show correctly, choose from the drop-down arrow on the left side an encoding that is appropriate for your language. By default, ANSI is selected there. For Bulgarian, for example, I'll need to change that to Cyrillic.
  • If your downloaded video doesn't want to play for some reason, check if it is in a SW-supported format. If it is, then your problem likely is with the video codecs. Recommended is the K-Lite codec pack.
  • If you're using Windows 7 and you're getting only a black screen when playing the video, try the solution shown in this video. Some have said that changing the option to "All supported" instead of "yv12" worked better for them.


Final thoughts

  • You can bookmark this page and consult with it often, until you gain good experience with the things explained here. There are other ways to achieve results, but the abovementioned ways are the best I've found after years of work. Be sure to give them a chance, even if you've already established your own work habits. Failing to do this might mean spending many hours running through the processes in an inefficient way. And if you've discovered things that are more efficient or can improve this tutorial in any way, be sure to share them!
  • If you're totally new to all of this, my suggestion is to go slowly and get used to the various functions one by one. Practice them and gradually expand your repertoire - the number of commands you understand and are skilled in. Becoming skilled in more and more commands means that you will give more and more attention to the various aspects of quality, while gradually becoming conscious of many details of the subtitling process. And, after all, achieving mastery in something is not about how much you know, but how much you are willing to learn.